Urgent : Login issues - Sign in with Google

Hi I have just installed the stable SP2 version on my pc what is a Lenovo M92 everything works but cannot sign in after install.

Steps taken

Sign in to your fyde os - works ok

Do you want to continue sign-in with fyde or google /

I chose Google entered my email and password.

I get the notification a device is trying to sign in and I say yes on my phone.

So the password is correct but then comes up with a verification failed check keyboard layout.

I’m in the UK my keyboard is UK language English United Kingdom and says GB at the bottom right of screen.

Please help ASAP as I really wanna get to try this out for the first time.

Update :

Says same message when choosing keep using Fyde Account and now stuck on a please wait screen be on it for at least 10 minutes.

Once setup will I be able to sign in later with my Google account if this issue can be solved?

it’s a known issue caused by an unrecognised tpm chip in your system. We have fixed this in the coming release, which will be out very soon. Stay tuned please.

Isn’t they a work around? No matter what options I choose I can’t sign in with Fyde OS account on email or phone number or Google account.

Disabled TCG security device in bios Google sign in works problem solved