Enabling Mock Locations - Chromebook Pixel 2013


I’ve recently installed FydeOS on my Chromebook Pixel 2013.

I want to enable mock locations as detailed HERE but I cannot get the RSA authorisation box to authorise the device when I connect to the ADB server. The device therefore remains unauthorised and I cannot proceed any further.

Can anyone help?
Thanks in advance :slight_smile:

ADB has been failing on recent versions, it’s known and we are looking into this.

Can you help with a work-around instead of me waiting for it to be fixed in a future update?

I’ve noticed when I first try to connect to, adbkey and adbkey.pub files are created in /home/chronos/user/.android

I then copied these over to /opt/google/containers/android/rootfs/android-data/data/misc/adb/adb_keys which is where I think they need to be for authorisation but the device is still showing as unauthorised.

I’m out of ideas. Can this problem be solved with a manual work around like I’m trying to do or is the problem much more complicated?

I don’t mind spending time doing trial and error but I’m a linux novice so I don’t really know what to try next.

We did some trial & error on this one and made some progress, you were on the correct track. It worked for us under the Crostini (Linux [beta]) shell rather than the Crosh shell, that I believe should be indifferent to your needs to run some adb commands.


  • Fire up Linux(beta) and do an usual full apt house-keep
  • Install adb
  • Fire-up adb to get the adbkey.pub file
  • Copy the content of adbkey.pub from Linux(beta) to /opt/google/containers/android/rootfs/android-data/data/misc/adb/adb_keys in a Crosh shell
  • Ensure ownership of adbkey.pub is 656360:657360
  • On Crosh shell kill adbd
  • On Linux(beta) issue adb connect arc, then FydeOS Android should be hooked.

Commands example:

# chronos@localhost denotes Crosh shell
# fydeos@penguin denotes Linux(beta) shell

fydeos@penguin$ sudo apt update && sudo apt upgrade -y
fydeos@penguin$ sudo apt install adb
fydeos@penguin$ adb start-server
fydeos@penguin$ cat ~/.android/adbkey.pub

#copy the displayed keys

chronos@localhost$ sudo vim /opt/google/containers/android/rootfs/android-data/data/misc/adb/adb_keys

# paste the copied key in a new line

chronos@localhost$ sudo chown 656360:657360 /opt/google/containers/android/rootfs/android-data/data/misc/adb/adb_keys

# reboot or kill adbd from Crosh shell

fydeos@penguin$ adb connect arc
fydeos@penguin$ adb devices #verify if they are shown as below

Success screenshot:

Let me know how it goes for you.

This worked perfectly, thanks! I’ve been able to use ADB for what I wanted.

There was a small problem generating the adbkey.pub file because it was saved in the /home/chronos/user directory. It was my first time using the vim command so maybe I wasn’t using all the attributes, I moved the file over to adb_keys and everything worked.

Excellent tech support, I’ll be subscribing when my evaluation runs out :+1:

1 个赞