cros pi login issue

Hello, I finally got networking now, I can open using guest mode

but in login window, after email/password, it displays below error message then back to login window again

i even created a new account, it’s the same, after login, it goes to that same error message …

anyone came across this issue? any solution?

btw, i google this error, this issue is not in below list:

thank you!

in guest mode, the OS and Chromium sessions only exist in RAM, so things could be quite different and obviously performance is heavily impacted

what were you trying to login to?

side note: is your Chromium OS having the correct data/time?

@alpha , thanks for the reply

I was trying to login to chromebook, my network can’t do this before, today I fixed network

After booting, it goes to the login window, it’s that that login I was talking about

on the subject line you wrote it was “cros pi login issue”, was that from your Chromebook or from chromium os pi image?

if it is chromium os, the /var/log/chrome and/or /var/log/messages may help to diagnose what happened behind the scene

@alpha, I’m using chromium os raspberry pi image

I was not able to login because of network

@alpha, the log files are uploaded

btw, in the same device, i can use guest to login to google, youtube, no issue at all

messages.1.txt (1.2 MB) messages.txt (760.4 KB) chrome_20210110-010248.txt (14.1 KB) chrome_20200101-160004.txt (24.7 KB)

@alpha, i’ll be damned, the fydeos image from github is working …
but my own built doesn’t …

the differences that i know of:

  1. i was using vanilla chromium source
  2. i removed widevine from ebuild
  3. i removed fydeos shell daemon from ebuild
  4. i removed kisok mode from ebuild
  5. when i build the biggest package chromeos-chrome, googleapi key was not provided, so when i boot up, there’s always message saying api key not provided

that’s all i can think of…

what could be the issue that caused login error?

it’s obviously the Google API keys. You will need Google API to sign in to Google account and utilise other supporting Google services.

You can however retrofit a google API key to your existing build at runtime by wracking it in as chrome dev flags.

side note: We have not released FydeOS for Raspberry Pi, yet. The one you downloaded was Chromium OS for Raspberry Pi.

@alpha, thanks a lot! let me try tonight, i’ll let you know

@alpha, i’m terribly sorry to have bothered you over and over again …
i got another issue, it seems /etc/chrome_dev.conf file is read only …

i tried editing file somewhere else, copying it using usb drive, then to system drive

chronos@localhost ~ $ sudo cp ~/Downloads/chrome_dev.conf /etc 
cp: cannot create regular file '/etc/chrome_dev.conf': Read-only file system

chronos@localhost ~ $ sudo rm /etc/chrome_dev.conf
rm: cannot remove '/etc/chrome_dev.conf': Read-only file system

the image was created with --noenable_rootfs_verification flag…

how can i edit /etc/chrome_dev.conf to append googleapikeys?

no worries, i get paid to do this :new_moon_with_face:.

you will need:

sudo mount -o remount rw /

to mount your rootfs to be writable.

1 个赞

@alpha, wow, i didn’t expect to get instant reply
you’re my hero! i’m rebooting now, moment of truth


thanks a lot!

1 个赞